Crashes when saving...

Amiga Game
Post Reply
Cego
Posts: 13
Joined: Mon Oct 17, 2022 8:25 am

Crashes when saving...

Post by Cego »

A few days ago I have updated Aquabyss to the newest version via in-game server update. Then I have loaded and resaved a gamestate.
Unfortunately the game kept crashing at every other save attempt. Saving worked though, so resetting the machine and loading was no problem.
After playing a few hours I got back to London, but can't leave the city. Yesterday my fuel went down to 0 immediately after leaving the docks and today I got this guru requester, when I try to leave the city
Please fix my save game as I don't want to start again from scratch!

Machine is an A1200 with V1200
IMG_1479.jpeg
User avatar
Aged Code
Developer
Posts: 393
Joined: Mon Aug 01, 2022 10:58 am
Location: Studio
Contact:

Re: Crashes when saving...

Post by Aged Code »

Hi Cego. Nobody reported such a problem except you, and people play and save the game a lot, so it's safe to say it's not the game's problem. But I'll look into your save of course (assuming it's on the server).

One question though. Did you update the V1200 core since the last play? It has to be either the core or something in your system.

Update:
Loaded your game (in Hamburg). I left the city and I made ten consecutive save games (including docking in another city and leaving it too). No problems at all, your save is perfectly fine as well as the game (I used the same version that's on the server for the record).
Cego
Posts: 13
Joined: Mon Oct 17, 2022 8:25 am

Re: Crashes when saving...

Post by Cego »

I did make an update to a newer beta core but went back and problems still remained. I will try a fresh install. Thanks a lot
User avatar
Aged Code
Developer
Posts: 393
Joined: Mon Aug 01, 2022 10:58 am
Location: Studio
Contact:

Re: Crashes when saving...

Post by Aged Code »

Was there a network driver update for A1200? If so, it's worth trying the previous one. Just try every possible option that has changed in your system since.
Also, try this: Boot the system without startup-sequence and play the game without the network feature. This is the best and safest test that one can do.
Post Reply